PHPのバージョンを上げる準備開始^^

スポンサーリンク

私のサイトはをwordpressで運用していますが、管理画面のダッシュボードにPHPバージョンを
上げ上げなさいとのメッセージがしばらく表示されています^^

Web系の仕事をしている仲間と電話していたところ、早めに対応したほうがいいそうなので、準備開始・・・

何か月も前からこのような表示が出ています。

皆さんのwordpressサイトも表示されてたまま、放置しているのではないでしょうか!?

普通にwordpressを使っているだけなら、サーバのPHPバージョンを上げるだけで特に対処は不要だと
思うのですが、私のwordpressは勉強用に作った自作の関数がPHP5用なので、一部仕様が合わない
ところが出るのではと教えてもらいました^^

自作関数のほとんどはアメブロから引っ越しした際のテーブル調整用なので、削除してしまえば
よさそうですが、一部表示用の機能にも流用しているのでバッサリ削除できなさそう・・・

設計がよくないなぁ~、と思いながらもこの機会に修正しておいた方がよさそうです

前回、PHP5→7に更新したときにサイトをぶっ壊したので今回は注意しないと・・・

とりあえず、全バックアップを取って作業開始^^

そんな、サイト更新開始の記録・・・

スポンサーリンク

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

日本語が含まれない投稿は無視されますのでご注意ください。 本文に全角文字を2文字以上含めて下さい (スパム対策)